ITKeyword,专注技术干货聚合推荐

注册 | 登录

Eclipse安装Maven Integration for Eclipse报缺少org.slf4j.api的错误的解决方案

yuxiangji 分享于 2014-02-18

推荐:error:Eclipse - Failed to load class “org.slf4j.impl.StaticLoggerBinder”解决方案

原文地址:http://stackoverflow.com/questions/13473953/eclipse-failed-to-load-class-org-slf4j-impl-staticloggerbinder 当编译maven工程遇到SLF4J: Failed

2019阿里云全部产品优惠券(新购或升级都可以使用,强烈推荐)
领取地址https://promotion.aliyun.com/ntms/yunparter/invite.html

Maven Integration for Eclipse的仓库地址是:Sonatype M2Eclipse - http://download.eclipse.org/technology/m2e/releases

安装时报错:

Cannot complete the install because one or more required items could not be found.
  Software being installed: m2e - slf4j over logback logging (Optional) 1.4.0.20130601-0317 (org.eclipse.m2e.logback.feature.feature.group 1.4.0.20130601-0317)
  Missing requirement: Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.core.ui 1.4.0.20130601-0317) requires 'bundle org.slf4j.api 1.6.2' but it could not be found
  Cannot satisfy dependency:
    From: m2e logback appender 1.4.0.20130601-0317 (org.eclipse.m2e.logback.appender 1.4.0.20130601-0317)
    To: bundle org.eclipse.m2e.core.ui [1.4.0,1.5.0)
  Cannot satisfy dependency:
    From: m2e - slf4j over logback logging (Optional) 1.4.0.20130601-0317 (org.eclipse.m2e.logback.feature.feature.group 1.4.0.20130601-0317)
    To: org.eclipse.m2e.logback.appender [1.4.0.20130601-0317]


解决方案:

推荐:Ubuntu10.4 下eclipse安装ADT时遇到org.eclipse.wst.sse.core 0.0.0缺失的一个解决方案

Ubuntu下eclipse安装ADT时遇到org.eclipse.wst.sse.core 0.0.0缺失的一个解决方案 遇到这个问题,在网络上找 今天在Ubuntu下用eclipse配置Android开发环境,在配

先安装slf4j.api,它的仓库地址是:slf4j - http://www.fuin.org/p2-repository/

选择:Maven osgi-bundles下的slf4j-api一项安装即可,完成之后,再安装M2E。



参考:

http://stackoverflow.com/questions/17352485/error-m2e-install-in-eclipse

推荐:Ubuntu下eclipse安装ADT时遇到org.eclipse.wst.sse.core 0.0.0缺失的一个解决方案

今天在Ubuntu下用eclipse配置Android开发环境,在配置ADT时出现如下错误:  1 Cannot complete the install because one or more required items could not be f

Maven Integration for Eclipse的仓库地址是:Sonatype M2Eclipse - http://download.eclipse.org/technology/m2e/releases 安装时报错: Cannot complete the install because one or more req

相关阅读排行


用户评论

游客

相关内容推荐

最新文章

×

×

请激活账号

为了能正常使用评论、编辑功能及以后陆续为用户提供的其他产品,请激活账号。

您的注册邮箱: 修改

重新发送激活邮件 进入我的邮箱

如果您没有收到激活邮件,请注意检查垃圾箱。