ITKeyword,专注技术干货聚合推荐

注册 | 登录

【SQL】关于低版本SQL附加高版本数据库(ERROR:948)的解决方法

SugaryoTT 分享于 2016-07-26

推荐:Sql Server数据库被置疑后解决方法

现象:数据库Log日志太大了,shrink不掉。于是想把数据库文件卸下来,删除log,再附加上。附加失败。 提示错误: 服务器: 消息 1813,级别 16,状态 2,行 1 未

2019阿里云全部产品优惠券(新购或升级都可以使用,强烈推荐)
领取地址https://promotion.aliyun.com/ntms/yunparter/invite.html

写在前面的

  • 最近在使用数据库的时候出现了一些小问题,具体来说就是SQL Server 2008附加SQL Server 2014数据库的时候出现了错误:948,在网上查找了一些方法最终搞定了这个问题,下面就贴出具体的解决方案。

    推荐:使用的 SQL Server 版本不支持数据类型“date”的解决方法

    分析错误产生的原因: GridView是利用SqlDataSourse进行数据绑定,在绑定的时候生成Insert,Delete,Update语句,然后启用编辑和删除功能,但是在运行时候,点击

  • Tips:微软官方已经明确承认,高版本的数据库文件(MDF、LDF)是不能附加到低版本的SQL Server上的,所以网上那些开一个服务就可以的做法根本行不通。

解决方法

生成数据库脚本

  • 首先,我们需要在高版本SQL Server中生成需要往低版本附加的数据库的脚本,具体操作如下:

    • 右击需要附加的数据库—>任务—>生成脚本。
      这里写图片描述
  • 然后,根据下图中默认的设置生成数据库脚本就OK了。(这里并不存在是是否生成低版本数据库脚本的概念,除非微软疯了把SQL语言全部重写,否则所有的数据库脚本语言都是一样的,放心的生成吧。)

    • 然后点下一步—>下一步—>下一步……
      这里写图片描述
      这里写图片描述
  • 最后,我们需要在低版本的SQL Server中新建一个数据库(不是附加数据库),然后双击刚才生成的数据库脚本文件,在这个建好的数据库中执行脚本文件,表就被建好了。

总结

  • 这样的做法可以让高版本的数据库可以在低版本的库上面实现“附加”,但是无法将里面的数据一起拷贝。如果想要将高版本的数据也导入到低版本的数据库中,那就需要“导出数据”了,导出数据的方法有很多,这里就不再赘述了,总之,数据库的使用方法有很多,多多总结少出错误才能慢慢进步。

推荐:SQL Server 2005 Express附加(Attach)的数据库为“只读”的解决方法

在许多数据库操作的源代码中,包含数据库,但是在“附加”数据库时候出现如下提示: 标题: Microsoft SQL Server Management Studio --------------------------

写在前面的 解决方法 生成数据库脚本 总结 写在前面的 最近在使用数据库的时候出现了一些小问题,具体来说就是SQL Server 2008附加SQL Server 2014数据库的时候出现了错误:948,在网上查找了一

相关阅读排行


用户评论

游客

相关内容推荐

最新文章

×

×

请激活账号

为了能正常使用评论、编辑功能及以后陆续为用户提供的其他产品,请激活账号。

您的注册邮箱: 修改

重新发送激活邮件 进入我的邮箱

如果您没有收到激活邮件,请注意检查垃圾箱。