ITKeyword,专注技术干货聚合推荐

注册 | 登录

Ruby on Rails Installation on windows xp

分享于 2011-10-23

推荐:ruby on rails 开发环境安装 for windows

1.github 注册 github.com 2.git windows 版本下载 http://code.google.com/p/msysgit/downloads/listcan=3&q=official+Git 3.ruby 1.8.7 下载 安装 http://www

2018阿里云全部产品优惠券(新购或升级都可以使用,强烈推荐)
领取地址https://promotion.aliyun.com/ntms/act/ambassador/sharetouser.html?userCode=gh9qh5ki&utm_source=gh9qh5ki

 You can get all the msgs below listed on the net. Try to google 'ruby on rails ', you can get a more detailed page. But it may occur some errors during your installation, follow the tip, you can sovle it.

1.rubyinstaller-1.9.2-p290.exe

2.rubygems-1.8.9,  extract, then run "ruby setup.rb"  

3.DevKit-tdm-32-4.5.2-20110712-1620-sfx.exe(needed  on gem install rails)

Installation

  • DevKit-tdm-32-4.5.2-20110712-1620-sfx.exe,ruby dk.rb init to generate the config.yml file to be used later in this Step. Your installed Rubies will be listed there (only those installed by a RubyInstaller package are detected at present).
  • edit the generated config.yml file to include installed Rubies not automagically discovered or remove Rubies you do not want to use the DevKit with.
  • finally, ruby dk.rb install to DevKit enhance your installed Rubies. This step installs (or updates) an operating_system.rb file into the relevant directory needed to implement a RubyGems pre_install hook and a devkit.rb helper library file into <RUBY_INSTALL_DIR>\lib\ruby\site_ruby. NOTE: you may need to use the --force option to update (with backup of the originals) the above mentioned files as discussed at the SFX DevKit upgrade FAQ entry.

Test Installation

  • Confirm your Ruby environment is correctly using the DevKit by running gem install rdiscount --platform=ruby. RDiscount should install correctly and you should see Temporarily enhancing PATH to include DevKit... in the screen messages. Next run ruby -rubygems -e "require 'rdiscount'; puts RDiscount.new('**Hello RubyInstaller**').to_html" to confirm that the rdiscount gem is working.

4.Gem install rails(Rails3.1.1)

Test

Rails new tutorial(create a web app)

Rails s(start server)

 You can get all the msgs below listed on the net. Try to google 'ruby on rails ', you can get a more detailed page. But it may occur some errors during your installation, follow t
在线网页数据采集器

相关阅读排行


用户评论

游客

在线网页数据采集器

相关内容推荐

vivo京东自营官方旗舰店

最新文章

×

×

请激活账号

为了能正常使用评论、编辑功能及以后陆续为用户提供的其他产品,请激活账号。

您的注册邮箱: 修改

重新发送激活邮件 进入我的邮箱

如果您没有收到激活邮件,请注意检查垃圾箱。