ITKeyword,专注技术干货聚合推荐

注册 | 登录

MAVEN的下载和安装-Unsupported major.minor version 51.0

bestcxx 分享于 2016-08-05

推荐:Mac Maven 安装错误 Error Unsupported major.minor version 51.0

最近在研究maven,在配置maven之后,运行mvn - v出现错误 Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli

2019阿里云全部产品优惠券(新购或升级都可以使用,强烈推荐)
领取地址https://promotion.aliyun.com/ntms/yunparter/invite.html

1、下载

http://maven.apache.org/download.cgi


2、注意jdk版本提示



3、将下载的文件解压到某个目录

比如D:\apache-maven-3.3.9


注意其中的 /conf/setting.xml


4、配置环境变量

先要配置好jdk



然后是MAVEN的配置:M2_HOME



在path中配置



检测

echo%M2_HOME%

mvn -v




可能出现的问题-jdk版本不符造成的,更换jdk版本根据2



Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ma ven/cli/MavenCli : 


Unsupported major.minor version 51.0


5、下本本地MAVEN库

如果你不指定的话,它会自动的把文件下载到某个位置

具体看   %M2_HOME%/bin/m2.conf 中的内容,你可以看到 set maven.home default ${user.home}/m2

所以注意,这个是具有全局效应的

但是 %M2_HOME%/conf/settings.xml 文件则是在被外部应用的时候,告诉外界其所在的位置,也是可以具有全局效用的

如果这个路径下,已经下载了maven库,则运行下面的命令也不会从新下载

运行 mvn help:system


系统自动下载至:C:\Users\username\.m2

推荐:Unsupported major.minor version 51.0

解决Unsupported major.minor version 51.0错误 最近新安装使用了jdk7,编译了一些类替换到原来正常运行的项目中,替换之后发生了Unsupported major.minor versi



文件夹名字叫做:.m2


之后你可以把这个.m2文件夹剪切到其他位置,然后修改/conf/seetiings.xml文件的内容,里面的内容需要指定到本地jar所在的位置

 如:

  <localRepository>D:/softwareplace/apache-maven-3.3.9/maven_here/.m2/repository</localRepository>


6、获取pom文件和jar文件

路径为:

~\.m2\repository\org\apache\maven\plugins\

了解maven插件 http://www.infoq.com/cn/news/2011/04/xxb-maven-7-plugin/


7、eclipse安装maven插件




直接下载有插件的eclipse

http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/lunasr2


下载地址-不要随便下载,看下下面对应版本的jdk要求 http://www.eclipse.org/downloads/packages/release/Mars/2 对应jdk版本要求 http://wiki.eclipse.org/Eclipse/Installation#Eclipse_4.6_.28Neon.29



这是页面提示已有的插件列表






Help->Install New Software


下面的网址  http://m2eclipse.sonatype.org/sites/m2e ,点开Avaliable Software Sites 看有没有,如有有就不用手动写了(但是自带版本可能在安装过程中报错,因为落后版本的网络可能比较差),否则选择Add(建议选add,选择第一个版本,然后是一个漫长的等待时间)

报错参考:http://smallwildpig.iteye.com/blog/1746763




注意,右边的Hide items that are already installed 不要勾选




当然,也可以直接下载有插件的

http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/lunasr2

推荐:Unsupported major.minor version 52.0

 java.lang.UnsupportedClassVersionE rror: PR/Sort : Unsupported major.minor version 52.0这个错误是由于高版本的java project使用了低版本的来运行 。 解

1、下载 http://maven.apache.org/download.cgi 2、注意jdk版本提示 3、将下载的文件解压到某个目录 比如D:\apache-maven-3.3.9 注意其中的 /conf/setting.xml 4、配置环境变量 先要配置好jdk

相关阅读排行


用户评论

游客

相关内容推荐

最新文章

×

×

请激活账号

为了能正常使用评论、编辑功能及以后陆续为用户提供的其他产品,请激活账号。

您的注册邮箱: 修改

重新发送激活邮件 进入我的邮箱

如果您没有收到激活邮件,请注意检查垃圾箱。